Aller au contenu
Bruno19652

Charge ne démarre pas avec la VE tronic en heures creuses

Messages recommandés

Bonjour 

j’ai une borne VE tronic pour pouvoir utiliser les heures creuses 

lorsque je branche ma voiture le soir, la borne attends les heures creuses pour démarrer la charge. Mais la borne n’arrive pas à réveiller la voiture lorsque ça bascule en HC.

il faut que je regarde l’application, la voiture se réveille et la charge commence immédiatement.

Quelqu’un à t il déjà rencontré ce problème ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai une borne qui permet aussi les charges HC mais je ne l'ai pas activé, je laisse la voiture gérer, elle sait à quelle heure démarrer la charge. Et si je dois lancer en dehors, juste on bouton à appuyer dans la voiture. L'avantage ? C'est surtout quand je mets une heure de départ en dehors des HC pour le préchauffage. Si la borne gère les HC, pas possible de préchauffer en HP, si la voiture gère, oui.
Avec la Tesla model 3, vous pouvez la programmer pour une heure de charge à un lieu donné, elle démarrera toute seule la charge à l'heure voulue, ça résoudra votre problème (en désactivant la gestion HC sur la borne).
De plus, la Tesla aime être raccordée à une source active, même si elle ne recharge pas

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 33 minutes, Bruno19652 a dit :

j’ai une borne VE tronic pour pouvoir utiliser les heures creuses 

lorsque je branche ma voiture le soir, la borne attends les heures creuses pour démarrer la charge. Mais la borne n’arrive pas à réveiller la voiture lorsque ça bascule en HC.

Bonjour.

 

Ce problème a déjà été cité par @Hart 

 

 

Il semble que ce soit un bug de la voiture.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je n'ai pas eu ce problème les 3-4 fois où j'ai chargé sur une borne comme ça chez mes parents. 

Ils ont par contre ce souci avec la Zoé depuis le début. 

Solution : lancer une "mini charge" de quelques secondes quand on branche la voiture, et ensuite au moment du passage en heures creuses elle se chargera bien. 

 

Mais je réitère : sur la Model 3 (et sur une S100D aussi) je n'ai jamais eu besoin de faire ça pour que la charge démarre en heures creuses. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok merci pour vos suggestions, je vais tester la recharge programmée et enlever les HC sur la borne 

Partager ce message


Lien à poster
Partager sur d’autres sites

Et tu te prendras moins la tête si un jour du dois faire une charge en heures pleines :la désactivation est toujours plus simple a gérer depuis l'interface de la voiture que sur la box.

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai le même problème, la gestion de la charge est faite depuis l'ordinateur de bord, du coup si la voiture est en veille le fonctionnement est très aléatoire.

je charge toutes les nuits en HC à 20A, et à 32A après un grand trajet.

j'ai très souvent eu des charges à 16A/32A ( visible sur l'appli ! ) ou 16A/20A... et je devais faire un arret de charger et relancer pour que la bonne valeur soit prise en compte.

si en cours de charge je demande à changer la puissance, même problème la voiture n'en tient compte que si je relance l'appli sur le téléphone. ( ma domotique peut reconfigurer la charge de la tesla quand la i3 a fini de charger )

 

mais depuis la version 2019.20.1, là c'est le pire j'ai carrément des matin ou la voiture n'a pas charger de la nuit...

 

Sur un forum US, j'ai vu que les utilisateurs qui synchronisent leur charge avec des panneaux solaires ont le même problème...

 

je suis train de regarder du coté des api tesla pour que ma domotique envoi 2 ordres à 22h01:

https://www.teslaapi.io/vehicles/commands

"Wake Up" puis "Start Charging"

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour ceux qui ont le problème, voici le script que j'ai ajouter à ma domotique, je le lance à 22h05, et à chaque changement de puissance de ma borne.

#!/bin/bash
#Script Name: tesla-charge.sh
#Author: Guillaume VALET sur la base du script de climatisation de Doug Fuhrer
#Credit to Tim Dorr's documentation of the tesla API

######### Define Your Credentials Here for authentication #######
#enter your email and password here
email="[email protected]"
password="SuperPasswordBienCommeIlFaut"
######### End Credential Definition ################

######### Enter a pin drop location where you want auto start to occur #######
### Use google maps to find the lattitude and longitude of where you usually park yor car ### 
#enter lattitude here. If your in US its usually the positive number 
slat="0.000000"
#enter longitude here. If your in US its usually the negative number
slon="0.000000"
######### End location definition ##################

#This function calculates the "geofence" off of the location specified for the pin drop
function calcgeo
{
        #calc the min and max longitude 
        clon_min=$(bc <<< "$slon - -.002558")
        clon_max=$(bc <<< "$slon + -.001977")

        #calc the min and max lattitude
        clat_min=$(bc <<< "$slat - .002566" )
        clat_max=$(bc <<< "$slat + .001987" )

        echo "geofence: Lattitude bounderies $clat_min, $clat_max and Longitude bounderies $clon_min, $clon_max" 
}

function wake
{
        awake="false"
        echo "getting token"

        data=$(curl -s -X POST \
        "https://owner-api.teslamotors.com/oauth/token?grant_type=password&client_id=81527cff06843c8634fdc09e8ac0abefb46ac849f38fe1e431c2ef2106796384&client_secret=c7257eb71a564034f9419ee651c7d0e5f7aa6bfbd18bafb5c5c033b093bb2fa3&email=$email&password=$password" \
        -H 'cache-control: no-cache')

        token=$(echo $data|awk -F ":" '{ print $2}'|awk -F "," '{ print $1}'|sed 's/"//g')

        echo "your token is $token"

        viddata=$(curl -s -X GET \
                https://owner-api.teslamotors.com/api/1/vehicles \
                -H "Authorization: Bearer $token" \
                -H 'cache-control: no-cache')

        vid=$(echo $viddata|awk -F ':' '{ print $3 }'|awk -F ',' '{ print $1 }')

        echo "your vid is: $vid"
        echo "waking up your car!"

while [[ $awake == "false" ]]
        do
                wakestat=$(curl -s -X POST \
                https://owner-api.teslamotors.com/api/1/vehicles/$vid/wake_up \
                -H "Authorization: Bearer $token" \
                -H 'cache-control: no-cache')

                wakedata=$(echo $wakestat|awk -F ',' '{ print $50 }'|awk -F ':' '{ print $2 }'|sed 's/"//g')
                echo "your car is $wakedata !"

                        if [[ $wakedata == "online" ]]
                                then
                                        awake="true"
                                fi
                sleep 10
        done
}

function locate
{
        echo "getting location of car!"
        locstat=$(curl -s -X GET \
        https://owner-api.teslamotors.com/api/1/vehicles/$vid/data_request/drive_state \
        -H "Authorization: Bearer $token" \
        -H 'cache-control: no-cache')

        loc=$(echo $locstat|awk -F ',' '{ print $3 , $4 }')

        echo "the location is $loc"

        lat=$(echo $loc|awk -F ':' '{ print $2 }'| awk -F ' ' '{print $1 }'|sed 's/"//g')

        lon=$(echo $loc|awk -F ':' '{ print $3 }'|sed 's/"//g')
}

function checkcharge
{
        chargedata=$(curl -s -X GET \
        https://owner-api.teslamotors.com/api/1/vehicles/$vid/data_request/charge_state \
        -H "Authorization: Bearer $token" \
        -H 'cache-control: no-cache')
        charge=$(echo $chargedata|awk -F ',' '{ print $2 }'| awk -F ":" '{ print $2 }')
		#pour plustard changer la puissance de la borne
        #curl -s http://openevse/r?rapi=%24SC+20
}

function startcharge
{
        tempstat=$(curl -s -X POST \
        https://owner-api.teslamotors.com/api/1/vehicles/$vid/command/charge_start \
        -H "Authorization: Bearer $token" \
        -H 'cache-control: no-cache')
}

function checkreq
{
# check if the location of the car is in "geofence"
if [[ $(bc <<< "$lat > $clat_min") -eq 1  &&  $(bc <<< "$lat < $clat_max") -eq 1 && $(bc <<< "$clon_min > $lon") -eq 1 && $(bc <<< "$clon_max < $lon") -eq 1 ]]
        then
                echo "car is between coordinates!"
                checkcharge
                echo "Charge $charge"
                sleep 10
                startcharge
                echo "Starting your charge now!" | mail -s "Domo Tesla" $email
        else
                echo "Your car is somewhere else no charge"
                echo "Not starting charge. coordinates are $lat , $lon ." | mail -s "Domo Tesla" $email
fi
}

##### Start of main! here we call out all of the above functions. #####

#wake up the car
wake

if [[ $awake == "true" ]] # if the car is awake then locate the car and run the rest of the automation
        then
        #calculate geofence
        calcgeo
        #locate the car
        locate 
        #check all reqs and start automation if met
        checkreq
fi

Il faut personnaliser les lignes :

email et password avec les infos de votre compte Tesla.

et pour que le script ne fonctionne que lorsque vous être chez vous, il test la localisation de la voiture.

au 1ier lancement vous recevrez sur votre email la position actuel de la voiture, et vous pourrez l'ajouter dans les 1ière lignes du script. 

 

 

 

 

Modifié par GuiToon

Partager ce message


Lien à poster
Partager sur d’autres sites

Récupération de ma model 3 hier ,

et elle a commencé sa charge ce matin a 7h00 quand j'ai ouvert l'appli Tesla sur mon téléphone.

VETronic paramétrée pour les heures creuses , et parfaitement fonctionnelle avec la ioniq.

 

quelle solution avez-vous appliqué et quelle est la fiabilité des solutions ?

  • recharge ne heure pleine ( c'est pas le but )
  • programmation horaire sur tesla
  • programmation domotique externe
  • modification code ve-tronic
  • vente de la voiture
  • tweet a elon

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Normal, la M3 ne comprend que sa langue d'origine 😉.

Programmation sur la voiture pour ma part.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 15/06/2019 à 15:12, GuiToon a dit :

si en cours de charge je demande à changer la puissance, même problème la voiture n'en tient compte que si je relance l'appli sur le téléphone. ( ma domotique peut reconfigurer la charge de la tesla quand la i3 a fini de charger )

 

Ton message m'inquiète , car j'ai choisi la VEtronic en grande partie pour le délestage.

Si la Tesla débute la charge a 32A et ne baisse pas la conso suivant la consigne de la wallbox , je risque de disjoncter !

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
il y a 4 minutes, alfniev a dit :

 

Ton message m'inquiète , car j'ai choisi la VEtronic en grande partie pour le délestage.

Si la Tesla débute la charge a 32A et ne baisse pas la conso suivant la consigne de la wallbox , je risque de disjoncter !

La Tesla prend ce que la wallbox lui donne. La recharge de la modèle 3 ce fait très bien avec une ve-tronic en délestage, ce matin encore comme depuis 15 jours, voiture chargée et chaude, malgré un abo en 6kVA. J'ai juste réglé le Max de charge à 25A dans la modèle 3.

 

@alfnievprobablement un conflit entre la programmation de la voiture et celle de la box. Perso, je laisse la modèle 3 gérer la charge en fonction de ce que la box lui donne. 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 32 minutes, alfniev a dit :

 

Ton message m'inquiète , car j'ai choisi la VEtronic en grande partie pour le délestage.

Si la Tesla débute la charge a 32A et ne baisse pas la conso suivant la consigne de la wallbox , je risque de disjoncter !

Bonjour,

 

j'ai beaucoup de problème aussi ces dernier temps le derniers firmware est catastrophique pour la charge.

 

en principe si ta box baisse la puissance disponible, la voiture va suivre, c'est une sécurité obligatoire.

C'est dans l'autre sens que c'est la foire.

Si la voiture est en veille la charge ne se lance pas, il faut la sortir de veille via les API ( fesable par script en domotique )

 

depuis longtemps souvent la voiture limite ma charge à 16A certaine nuit sans raison, alors que le consigne était 21, 24 ou 32 A.

Voici quelques exemples:

Screenshot_20190621-221704.thumb.png.067c4bd0be7bc22fd08806b178399b10.png  Screenshot_20190903-220857.thumb.png.3b46f974d5fb9358b106b805bf80f917.png

 

mais depuis cette semaine j'ai carrément des nuits avec pas de charge ou des coupure sans raison:

Screenshot_20191217-053807.thumb.png.61c1c55a3d3651272794d05fb858a982.pngScreenshot_20191217-054735.thumb.png.a2e4558c32fe0d5f0c4c1dc1977d5ee7.png

 

On voit que la voiture à coupé sa charge vers 23h sans raison, pour la reprendre un peu avant 2h. ( graph de la consommation total de ma maison directement prise sur le compteur )

Un possibilité c'est que la voiture trouve la tension trop basse ( 212V ) mais elle est dans les normes EDF ( 207 à 253 V, soit 230v à 10% )

 

malheureusement, il n'y a rien dans les API pour forcer une valeur de charge...

je suis en plein test pour ce problème, j'adapte mes scripts en envoyant l'ordre de commencer la charge ( + reveil de la voiture ) on verra dans le temps ce que ça donne.

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

J'ai aussi une Vetronic et domoticz.

 

J'ai pas ce pb... de coupure de charge et relance. Par contre il est probable que la tension électrique chez toi est trop basse... (et on voit bien que le reseau eletrique bosse pendant la recharge a 25A :) (Merci mon onduleur et Librenms pour ce graphe).

 

Capture d’écran 2019-12-20 à 11.09.12.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Lorsque ma model 3 est en veille, la Ve Tronic ne la réveille pas . Du coup je programme le début de charge à 01h30 et là ça fonctionne nickel 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, GuiToon a dit :

depuis longtemps souvent la voiture limite ma charge à 16A certaine nuit sans raison, alors que le consigne était 21, 24 ou 32 A.

De même et c'est très agaçant (avec l'umc je précise).

Partager ce message


Lien à poster
Partager sur d’autres sites

Il y a des programmes de réveil dans la Vetronic,  j'avais activé une option pour la Hyundai. Pas d équivalent pour la tesla ?

 

Vetronic a aussi une option pour ouvrir la trappe , en l activant cela réveille peut-être la voiture ?

 

Sinon je ferai bien confiance à la voiture en supprimant le paramétrage heures creuses de la voiture,  mais je recharge aussi la Hyundai avec la même wallbox....

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 50 minutes, alfniev a dit :

Il y a des programmes de réveil dans la Vetronic,  j'avais activé une option pour la Hyundai. Pas d équivalent pour la tesla ?

il y a des API qui permettent de faire tout ce que l'appli du téléphone peut faire.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 6 heures, Njxt a dit :

De même et c'est très agaçant (avec l'umc je précise).

ha ! ça ca me fait plaisir ! ( désoler pour toi ) 

car lors de mon appel à Tesla, on me répond que c'est à cause de ma borne, que UMC ou un WC n'aurait surement pas le problème...

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 11 heures, GuiToon a dit :

mais depuis cette semaine j'ai carrément des nuits avec pas de charge ou des coupure sans raison:

Tiens, j'ai ca aussi maintenant, 2 fois en 2 semaines, ce matin au reveil, la voiture n'avait que 41% de charge... un peu juste mais j'ai pu faire ma journée quand même.

Ca pourrait etre genant , je n'ai pas encore cherché d'où venait le problème mais si je ne suis pas le seul, effectivement, ca pourrait venir du firmware de la voiture

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, alfniev a dit :

Ton message m'inquiète , car j'ai choisi la VEtronic en grande partie pour le délestage.

Si la Tesla débute la charge a 32A et ne baisse pas la conso suivant la consigne de la wallbox , je risque de disjoncter !

J'ai une WB01 et la charge suis bien les infos du délestage, pas de souci.

Par contre j'avais remonté le problème du réveil en heure creuse voici la réponse de Cyril (c'était en mars de cette année):

 

"On m'a déjà remonté ce souci, c'est un bug de la Tesla model 3, celle-ci ne se réveille pas pour charger lorsque la borne lui indique qu'elle peut déclencher la recharge. Le véhicule doit se mettre en veille et ne se réveille pas quand la borne lui envoie l'ordre de charger.
Du coup en attendant que Tesla corrige le problème dans une future mise à jour, la seule solution c'est de configurer la borne en mode 0, et de programmer l'horaire de charge dans le véhicule."

 

Je programme donc la recharge si je la souhaite en heures creuse par la voiture.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci de nous avoir communiqué la réponse de Cyril.

 

Donc j'ai maintenant 2 VE avec des fonctionnement opposés :

  • hyundai ioniq  plus fiable quand la borne gère les heures creuses
  • Model 3 : qui doit avoir toujours l'énergie a dispo et programmer la voiture.

La solution simple serait une seconde wallbox pour la tesla. Mais c'est quand même idiot d'avoir une wallbox spécifique pour chaque véhicule.....

 

Question aux initiés , si

  • je branche l'UMC sur une prise commandé ( par le signal HC/HP comme pour le chauffe eau )
  • je branche l'UMC sur la voiture le soir
  • la voiture se mets en veille automatiquement
  • au début des HC , la prise commandée allume l'UMC

Est-ce que la model 3 va charger ?

 

NB : j'ai eu quelques mauvaises expérience avec le signal HC/HP de mon compteur , donc je préfèrerai que ce soit le signal du compteur qui pilote et pas un simple réglage horaire

Modifié par alfniev

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui ça va marcher, mais exactement comme avec ta borne, tu prends le risque que le as voiture ne sorte pas de veille, ou que le réglage d'intensité ne soit pas bon.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 9 heures, Bruno19652 a dit :

Lorsque ma model 3 est en veille, la Ve Tronic ne la réveille pas . Du coup je programme le début de charge à 01h30 et là ça fonctionne nickel 

Cela semble la solution la plus simple. et ca charge a 32A ? ou il y aussi des bugs sur la vitesse de charge ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, GuiToon a dit :

Oui ça va marcher, mais exactement comme avec ta borne, tu prends le risque que le as voiture ne sorte pas de veille,

Merci pour cette réponse qui dit OUI et NON a la fois , est-ce un fonctionnement aléatoire , parfois oui , parfois non ?

Partager ce message


Lien à poster
Partager sur d’autres sites



Automobile Propre

Automobile Propre est un site d'information communautaire qui est dédié à tout ce qui concerne l'automobile et l'environnement. Les thématiques les plus populaires de notre blog auto sont la voiture électrique et les hybrides, mais nous abordons également la voiture GNV / GPL, les auto à l'hydrogène, les apects politiques et environnementaux liés à l'automobile. Les internautes sont invités à réagir aux articles du blog dans les commentaires, mais également dans les différents forums qui sont mis à leur dispositon. Le plus populaire d'entre eux est certainement le forum voiture électrique qui centralise les discussions relatives à l'arrivée de ces nouveaux véhicules. Un lexique centralise les définitions des principaux mots techniques utilisés sur le blog, tandis qu'une base de données des voitures (commercialisées ou non) recense les voitures électriques et hybrides.

×
×
  • Créer...