Aller au contenu
GuiToon

[TUTO] Dashcam / Sentinelle : utiliser un Raspberry Pi en guise de stockage USB

Messages recommandés

C'était ma piste avant la dernière mise en veille, le package n'est installé d'aussi loin que remonte l'historique de mon terminal ... Je regarderai sérieusement demain.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, Belokan a dit :

C'était ma piste avant la dernière mise en veille, le package n'est installé d'aussi loin que remonte l'historique de mon terminal ... Je regarderai sérieusement demain.

Si tu utilises TeslaMate, c'est sympa de pouvoir désactiver la fonction Sleep pendant les bidouilles, ça évite quelques désagréments :)

Modifié par Zib Astian

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 21 heures, Zib Astian a dit :

Tu peux prendre de la SD Samsung EVO, pas cher et pas de soucis de perf.J'ai mis ça dans un Pi Zero et ça fonctionne à merveille

 

https://www.amazon.fr/dp/B06XFWPXYD/ref=twister_B071F2V5GK?_encoding=UTF8&psc=1

Je vais faire un test... Le dernier avant de dégager cette bidouille car franchement entre le RPI OW et le RPI 4 suis pas sûr que ça soit une solution stable dans le temps... (et honnêtement si je pouvais coller mon T5 directement au cul du PI 4...)

Partager ce message


Lien à poster
Partager sur d’autres sites

Aucun soucis de mon côté, et comme les partitions systèmes sont montées en read-only je n'ai jamais eu de corruption pour le moment. Pas de raison que ça n'aille pas chez toi :)

Modifié par Zib Astian

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 21 heures, kiwi35 a dit :

Bon, je reviens de tester avec les paramètres du kernel linux comme donnés précédemment : "clef usb trop lente". Ca me gonfle donc...

Je me disais aussi que c'était trop beau pour être vrai, de toute façon une sd card ne remplacera jamais un vrai SSD...

Je reviens au samsung t5.

... en attendant le Roadie de EV Tuning... (ça me gonfle).

Est-ce que tu as bien suivi les instructions données ici : https://github.com/marcone/teslausb/issues/239#issuecomment-543312156 ?

(Il faut utiliser la version beta en buster).

Moi c'est avec ça que les pb de USB trop lent ont disparus ...

 

Sinon je confirme, aucun soucis de corruption du filesystem.

 

A mon sens une carte SD de 128go (ou +) dans le Pi 0  fait largement bien le taf...

Partager ce message


Lien à poster
Partager sur d’autres sites

Complement... Donc soit c'est ma SD qui est lente soit c'est autre chose. La SD samsung est commandée on verra ce que ca donne.

Partager ce message


Lien à poster
Partager sur d’autres sites

Il ne répondait plus ce matin, j'avais installé/configuré dnsmasq + hostapd manuellement hier et ça fonctionnait. Je vais reflasher proprement en activant l'AP dès l'auto-config c'est pas normal qu'il ne veuille pas le faire sur ma distrib déjà up & running.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 11 heures, Belokan a dit :

Il ne répondait plus ce matin, j'avais installé/configuré dnsmasq + hostapd manuellement hier et ça fonctionnait. Je vais reflasher proprement en activant l'AP dès l'auto-config c'est pas normal qu'il ne veuille pas le faire sur ma distrib déjà up & running.

Si tu te connectes sur l'AP du Pi Zero alors qu'il est connecté à un réseau wifi, tout transfert plante au bout de quelques dizaines de Mo.

 

Par contre quand il n'est pas connecté à un réseau wifi, on-the-go, ça fonctionne nickel. Je pense que le contrôleur wifi du Pi Zero n'est pas prévu pour gérer plusieurs trucs en parallèle :)

Modifié par Zib Astian

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 06/01/2020 à 20:21, Zib Astian a dit :

Par contre quand il n'est pas connecté à un réseau wifi, on-the-go, ça fonctionne nickel. Je pense que le contrôleur wifi du Pi Zero n'est pas prévu pour gérer plusieurs trucs en parallèle :)

Le controleur et le CPU. Je viens de recevoir ma nouvelle SD... Je vais tester.... (on verra si c'est stable dans le temps, mais je doute).

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour l'instant ça fonctionne chez moi. Je viens de configurer le server samba (j'avais oublié de l'activer à l'installation).

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, aller verdict : ça merdoie, bien évidement, ce matin la "clef" usb n'étais plus visible après 2 minute de démarrage....

Bref, je retourne a mon Samsun T5 et j'arrête de perde du temps avec ce machin. Je vais plus l'utiliser avec mon plugin domoticz (by the way si qqn veux m'aider a coder je suis preneur).

Partager ce message


Lien à poster
Partager sur d’autres sites

Pas trop de problème chez moi. J'ai eu une ou deux fois le message de "clé USB lente" mais ça ne l'a pas empêché de faire une sauvegarde des dernières minutes quand j'ai appuyé sur l'icone caméra ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bah c'est soit via le hub Jeda qui fait que ça soit plus sensible soit le rpi zero w est trop lent. 

Bon en tous cas attendre ~1min que le rpi se bouge les doigts du... pour booter c'est trop lent...

Partager ce message


Lien à poster
Partager sur d’autres sites

Je pense que c'est moins d'une minute pour moi, mais j'ai jamais chronométré non plus ...

Je vais bricoler un câble "data only" pour brancher le PI0 à la voiture et l'alimenter via une batterie externe sur le port "power", mais faut que je passe le câble d'alimentation depuis le logement sous l'accoudoir pour brancher la batterie sur le 12V avant. Une fois alimenté de façon permanente il ne devrait plus s’éteindre.

Modifié par Belokan

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, Belokan a dit :

mais faut que je passe le câble d'alimentation depuis le logement sous l'accoudoir pour brancher la batterie sur le 12V avant. Une fois alimenté de façon permanente il ne devrait plus s’éteindre.

Tu peux le glisser sous le rebord qui part à coté d'un des 2 sieges... C'est quand même dommage que le logement sous l'accoudoir ne communique pas sur la partie avant (ou qu'on aie une trappe cachée pour y coller un dispositif tel le rpi / ssd)...

Partager ce message


Lien à poster
Partager sur d’autres sites

Oui j'ai vu une vidéo (i1tesla je pense) faudra quand même faire une petite encoche dans le plastique de la console pour passer le câble.

Tu peux faire une "trappe cachée" avec un Jeda HUB mais bon, $80 juste pour planquer le SSD/RPI et sortir 4 ports ça fait cher.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 5 heures, kiwi35 a dit :

Bah c'est soit via le hub Jeda qui fait que ça soit plus sensible soit le rpi zero w est trop lent. 

Bon en tous cas attendre ~1min que le rpi se bouge les doigts du... pour booter c'est trop lent...

J'ai le PI Zero branché dans le slot prévu pour la clé sentry du hub jeda. Ca mets effectivement 1 minute à apparaitre mais c'est quoi le soucis ? Je préchauffe souvent donc quand j'arrive à la voiture tout est OK et sinon, le temps de monter dans la voiture, boucler la ceinture, sortir du garage ou du parking... ça permet largement au Pi de booter et de démarrer l'enregistrement

 

Quand la voiture est dans la rue, Sentinel est activé et donc ça ne s'éteint de toute façon jamais.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, Belokan a dit :

Oui j'ai vu une vidéo (i1tesla je pense) faudra quand même faire une petite encoche dans le plastique de la console pour passer le câble.

Tu peux faire une "trappe cachée" avec un Jeda HUB mais bon, $80 juste pour planquer le SSD/RPI et sortir 4 ports ça fait cher.

Clair que c'est cher mais tout est propre : le Pi passe dans la trappe et rien ne dépasse. Ca évite de tirer sur les câbles en attrapant un truc au fond

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, Zib Astian a dit :

Ca mets effectivement 1 minute à apparaitre mais c'est quoi le soucis ? Je préchauffe souvent donc quand j'arrive à la voiture tout est OK et sinon, le temps de monter dans la voiture, boucler la ceinture, sortir du garage ou du parking... ça permet largement au Pi de booter et de démarrer l'enregistrement

Le problème principal, c'est que pour des raisons diverses et variées, la clef USB "emulée" des fois ne monte pas.

Il faudrai, mais le temps me manque hélas, que cette clef USB émulée soit formatée en ext3/ext4 pour dégager la lourdeur de la fat32 et le fait que le rpi fais un fsck du disk emulé avant le de présenter a la tesla...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, le Roadie viens de partir des US... Je ferai un p'tit test 😛

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon il suffisait de dire que ça fonctionne pour que ça commence à déconner ...

 

Hier soir en rentrant retour des messages carte lente et ce matin pas de logo Dashcam et pas d'USB dans les sources audio disponibles, J'arrête les frais avec ce gadget il est trop peu fiable pour être réellement utilisé.

 

@kiwi35 J'attends ton retour sur le Roadie, tu as pris quoi/où ?

Modifié par Belokan

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 07/02/2020 à 08:48, Belokan a dit :

Bon il suffisait de dire que ça fonctionne pour que ça commence à déconner ...

 

Hier soir en rentrant retour des messages carte lente et ce matin pas de logo Dashcam et pas d'USB dans les sources audio disponibles, J'arrête les frais avec ce gadget il est trop peu fiable pour être réellement utilisé.

 

@kiwi35 J'attends ton retour sur le Roadie, tu as pris quoi/où ?

Je croise les doigts, pas de soucis de mon côté pour l'instant

Partager ce message


Lien à poster
Partager sur d’autres sites



Automobile Propre

Automobile Propre est un site d'information communautaire qui est dédié à tout ce qui concerne l'automobile et l'environnement. Les thématiques les plus populaires de notre blog auto sont la voiture électrique et les hybrides, mais nous abordons également la voiture GNV / GPL, les auto à l'hydrogène, les apects politiques et environnementaux liés à l'automobile. Les internautes sont invités à réagir aux articles du blog dans les commentaires, mais également dans les différents forums qui sont mis à leur dispositon. Le plus populaire d'entre eux est certainement le forum voiture électrique qui centralise les discussions relatives à l'arrivée de ces nouveaux véhicules. Un lexique centralise les définitions des principaux mots techniques utilisés sur le blog, tandis qu'une base de données des voitures (commercialisées ou non) recense les voitures électriques et hybrides.

×
×
  • Créer...