Aller au contenu
denouche

API Status offline ?

Messages recommandés

Hello,

 

J'utilise les API Tesla pour obtenir le statut de la voiture, et jusque là j'avais obtenu 2 résultats :

- asleep : la voiture est en veille

- online : la voiture est réveillée

 

 

Mais je suis récemment tombé sur le cas du state "offline":

 


{
  "response": {
    "id": 12345,
    "vehicle_id": 12345,
    "vin": "5YJ...",
    "display_name": "Titine",
    "option_codes": "...",
    "color": null,
    "tokens": [
      "Xxx",
      "Yyy"
    ],
    "state": "offline",
    "in_service": false,
    "id_s": "12345",
    "calendar_enabled": true,
    "api_version": 7,
    "backseat_token": null,
    "backseat_token_updated_at": null
  }
}

 

 

J'ai fouillé un peu des forums anglais, rien de très probant.

De mon côté avec ma M3SR+ j'ai eu ce status offline hier soir, et à nouveau ce soir. Mais jamais avant. 

Et quand j'ouvre l'application officielle Tesla, l'application réveille bien la voiture, et j'entends le clac de la batterie. 

 

J'ai échangé avec @dvk qui lui a encore quelques chose plus étrange. Sa MS100D n'a jamais le statut "asleep". Elle passe de online à offline tout le temps ! Mais il a aussi le clac de la batterie quand il l'ouvre, donc c'est que la voiture ne passe pas 100% du temps réveillée. 

 

Des idées, des remarques ?

Qu'est-ce que cela signifie ?

Est-ce que le véhicule dort quand il est offline ?

Ou alors on ne peut pas le supposer tout le temps ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai de temps en temps le statut offline quand il n'y a pas assez de reseau au sous sol et également pendant des phases de connexion en wifi, donc offline n'est pas synonyme de asleep

Partager ce message


Lien à poster
Partager sur d’autres sites

A la lumière de ce que dit@fangiogreen , je comprend ce qui ce passe :
Jusqu'ici, la voiture était restée quasiment tout le temps au garage.
Hier, je suis sorti et j'ai eu le statut asleep (et les zzz sur l'appli).
Ce matin, à la maison, la voiture est en offline.

Je pense que la voiture capte le réseau wifi de la maison mais n'arrive pas à s'y connecter dans le garage. Je vais essayer en supprimant le reseau et normalement, le statut devrait remonter en asleep.

La voiture est pourtant bien joignable par 4G et elle a même été réveillée mardi par le serveur Tesla (vu dans les logs) pour lui signaler la dernière mise à jour.

Dans mon cas, le offline voudrait dire un peu connecté au wifi mais pas trop...

Partager ce message


Lien à poster
Partager sur d’autres sites



Automobile Propre

Automobile Propre est un site d'information communautaire qui est dédié à tout ce qui concerne l'automobile et l'environnement. Les thématiques les plus populaires de notre blog auto sont la voiture électrique et les hybrides, mais nous abordons également la voiture GNV / GPL, les auto à l'hydrogène, les apects politiques et environnementaux liés à l'automobile. Les internautes sont invités à réagir aux articles du blog dans les commentaires, mais également dans les différents forums qui sont mis à leur dispositon. Le plus populaire d'entre eux est certainement le forum voiture électrique qui centralise les discussions relatives à l'arrivée de ces nouveaux véhicules. Un lexique centralise les définitions des principaux mots techniques utilisés sur le blog, tandis qu'une base de données des voitures (commercialisées ou non) recense les voitures électriques et hybrides.

×
×
  • Créer...