Aller au contenu
cedric2

Forum • Nissan connect for Jeedom

Messages recommandés

Bonjour Cédric,

 

Merci pour ton travail sur le plugin.

 

Voici mon retour d'expériences :

 

J'ai installé (ce mercredi) le plugin sur un Raspberry Pi (avec l'image Jeedom officielle).

Aucune valeur n'est remontée, seul l'état "Charge ON" est indiqué.

Le message d'erreur en retour d'une demande d'actualisation est "Request for 'BatteryStatusCheckResultRequest.php' failed. Response received: {"status":404}".

 

Remarque : j'ai aussi installé (dimanche) Jeedom sur un NAS Synology (Docker). Le plugin fonctionnait en début de semaine (sauf pour la capacité figée à 0 et la capacité restante donnant une valeur très faible de l'ordre de 11 Wh avec 120 km d'autonomie) mais depuis le 4 avril à 7h15, date de la dernière mise à jour.

Message d'erreur lorsque je demande l'actualisation : "Missing 'RemoteACRecords' in response received in call to 'RemoteACRecordsRequest.php': {"status":200}"

 

Nissan Connect fonctionne.

 

Mon Jeedom sur RPi fonctionne correctement, les autres plugins ne posent pas de problème.

 

J'ai activé le mode debug pour les log, si cela peut t'aider.

 

Merci pour ton support.

 

A+

Tux

Partager ce message


Lien à poster
Partager sur d’autres sites

petit up

 

je confirme le post ci dessus, je rencontre aussi une non mise a jour du plugin

 

dans les log, j ai cette ligne qui reviens souvent

 

[2017-04-05 14:45:41][ERROR] : Erreur sur la fonction cron15 du plugin : Missing 'RemoteACRecords' in response received in call to 'RemoteACRecordsRequest.php': {"status":200}

 

accompagnée de temps en temps de :

 

[2017-04-05 15:05:05][ERROR] : Erreur sur la fonction cron15 du plugin : Timeout waiting for result using BatteryStatusCheckResultRequest.php

Partager ce message


Lien à poster
Partager sur d’autres sites

vous avez essayer de cliquer sur "arreter le chauffage" ? c'est idiot, je ne sais pas pourquoi mais cela débloque souvent le truc de "Missing 'RemoteACRecords' in response received in call to 'RemoteACRecordsRequest.php'"

Partager ce message


Lien à poster
Partager sur d’autres sites

mise a jour du plugin ce matin, a priori , il a l air OK maintenant

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour Cédric,

 

Merci pour le correctif, cela fonctionne de nouveau sauf pour la capacité (toujours à 0%)...

 

A+

Tux

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai oublié de dire merci

 

 

Merci Cedric

 

 

 

 

un petit bug gênant que je viens de trouver

j ai bien réussi a lancer la charge, mais le bouton pour arrêter n est pas efficace

dommage, elle charge donc en heures pleine :P

Partager ce message


Lien à poster
Partager sur d’autres sites
Bonjour Cédric,

Merci pour le correctif, cela fonctionne de nouveau sauf pour la capacité (toujours à 0%)...

Tux

tu as quoi comme leaf ?

tu as essayé de supprimer/recreer le template ?

Il faudrait mettre en débug, et me donner les log en MP (pas ici, car il y a le serial dans les logs)

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai peut etre crié victoire trop vite, pas de maj depuis le 12 ( hier ) 23:00

 

lorsque je lance une maj manuelle :

"Timeout waiting for result using BatteryStatusCheckResultRequest.php"

 

j ai desactivé, reactivé le plugin , reinstallé les dépendances

 

toujours pareil

 

j ai essayé d avoir plus de log ( mis en info ) , mais c est pas tres bavard

 

[2017-04-13 21:07:13][ERROR] : Erreur execution de la commande [Maison][ZekLeaf][Rafraichir] : Invalid 'OperationResult' received in call to 'BatteryStatusRecordsRequest.php': ELECTRIC_WAVE_ABNORMAL

[2017-04-13 21:07:17][iNFO] : in function execute

Partager ce message


Lien à poster
Partager sur d’autres sites

Il faut mettre en débug dans les reglages.

Tu as essayé de cliquer sur "chauffage off" ?

Partager ce message


Lien à poster
Partager sur d’autres sites

@Slartibartfast

Les anciennes voitures ne donnent pas le SOC (i.e state of charge)

on le voit dans tes log

[batteryCapacity] => 12

[batteryRemainingAmount] => 8

[batteryRemainingAmountWH] =>

[batteryRemainingAmountkWH] =>

[sOC] =>

[TimeRequiredToFull] =>

 

Donc on ne peut afficher que BatteryCapacity et BatteryRemainingAmount

 

On pourrait faire un petit hack pour afficher BatteryRemainingAmount / BatteryCapacity quand le soc n'est pas renvoyé...

 

dans core/class/nissan_leaf_connect.class.php remplace

$cmd->event($result->SOC);

par

$cmd->event($result->BatteryRemainingAmount /$result->BatteryCapacity ) ;

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

Automobile Propre

Automobile Propre est un site d'information communautaire qui est dédié à tout ce qui concerne l'automobile et l'environnement. Les thématiques les plus populaires de notre blog auto sont la voiture électrique et les hybrides, mais nous abordons également la voiture GNV / GPL, les auto à l'hydrogène, les apects politiques et environnementaux liés à l'automobile. Les internautes sont invités à réagir aux articles du blog dans les commentaires, mais également dans les différents forums qui sont mis à leur dispositon. Le plus populaire d'entre eux est certainement le forum voiture électrique qui centralise les discussions relatives à l'arrivée de ces nouveaux véhicules. Un lexique centralise les définitions des principaux mots techniques utilisés sur le blog, tandis qu'une base de données des voitures (commercialisées ou non) recense les voitures électriques et hybrides.

×